
Abbildung 1: Dialog für neues Bild

b

1 Öffen und Speichern

1.1 Erstellen eines neuen Bildes

Ein neues leeres Bild wird mit File -> New Image angelegt (oder Ctr+N).

• Image Size: Einstellen von Höhe und Breite des neuen Bildes

• Template-Menü: Standardbildgrößen (A4, Diskettenlabel, Toilettenpapier...)

• Voreinstellung Pixel

• Umstellung mit Menü

• Wenn Größe in Pixel eingestellt, dann wird die tatsächliche Pixelgröße
durch die X- und Y-Auflösung gegeben, wenn Dot-for-Dot im View Menü ein-
gestllt ist.

• X-Y-Auflösung kann im Menü Advanced Options eingestellt werden

• Kein Bild offen: Öffnet in neuem Fenster mit Standardgröße

• Bild offen: Öffnet in neuem Fenster mit der Größe des schon offenen Bildes

• Jedes Pixel wird abgespeichert. Große Bilder mit hoher Pixeldichte benöti-
gen lange Ladezeiten und Arbeitsspeicher

• Landscape/Portrait toggler: Vertauschen von Höhe und Breite und X-Y-
Auflösung
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• X-Y Auflösung: Beeinflussen die Größe des Bildes beim Drucken

• Dot-for-Dot im View Menü, Zoom 100%: Darstellen des Bildes am Bild-
schirm in der korrekten Größe

• Colorspace: Farbe & Graustufen

• Hintergrundfarbe (kann auch später noch geändert werden)

– Vordergrundfarbe (aus der Toolbox)

– Hintergrundfarbe (aus der Toolbox)

– Weiss

– Transparenter Hintergrund (gekachelt dargestellt)

• Kommentar: Wird als Parasit als zusätzliche Daten mit dem Bild gespei-
chert. Kann nachträglich im Image Properties Dialog geändert werden.

1.2 Speichern eines neuen Bildes

File -> Save

1.2.1 Bildformate

• BMP: wenig Farbverlust, sehr groß, und deshalb nicht geeignet für die
Veröffentlichung auf einer Homepage. Das Format kann keine transparen-
ten Bildbereiche darstellen.

• JPG beliebtes Format mit dem Photos und andere Grafiken mit vielen
verschiedenen Farben gespeichert werden. Je stärker die Komprimierung,
desto schlechter ist jedoch die Bildqualität.

• GIF ist ein Komprimierungsformat. Eignet sich für Grafiken mit wenigen
Farben. GIF kann transparente Flächen darstellen und kleine Bildfolgen
(Animationen) speichern.

• PNG ist eine weiteres Komprimierungsformat. Geeignet für alle Grafiken,
die man im Web veröffentlichen möchte. Die Komprimierung ist jedoch
nicht so stark wie bei Gif oder JPG. Kann Transparenz und Teiltranspa-
renz in Bildern darstellen.

• XCF: GIMP-eigenes Dateiformat; entwickelt, um alle GIMP-eigenen In-
formationen zu speichern (Pixeldaten für jede Ebene, aktuelle Auswahlen,
zusätzliche Kanäle, Pfade ...). Datei ist sehr groß, nur wenige Programme
außer GIMP können sie lesen.

1.3 Bild öffnen

1.3.1 EXIF Daten

Exchangeable Image File Format
Nahezu alle modernen Digitalkameras beherrschen den Exif-Standard und

speichern bei jeder Aufnahme zahlreiche wichtige Aufnahmeparameter wie zum
Beispiel:
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Abbildung 2: Speichern-Dialog

Abbildung 3: Einige Kameras schreiben Informationen über die Bildorientierung
in die EXIF Daten
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Abbildung 4: Menü Rechteckselektion und die Funktion Highlight

• Datum und Uhrzeit

• Orientierung (Hoch- oder Querformat)

• Brennweite

• Belichtungszeit

• Blendeneinstellung

• Belichtungsprogramm

• ISO-Wert (
”
Lichtempfindlichkeit“)

• GPS-Koordinaten (siehe Fotoverortung Geo-Imaging)

• Vorschaubild (
”
Thumbnail“)

2 Werkzeugkasten

Quelle: http://en.wikibooks.org/wiki/GIMP/Toolbox

2.1 Rechteckselektion

Rechteckselektion für die Auswahl von rechteckigen Bildausschnitten
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Abbildung 5: Rechteckselektion und die Funktion Add Selection

Abbildung 6: Rechteckselektion und die Funktion Feather Edges
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Abbildung 7: Rechteckselektion und die Funktion Rule of Thirds

2.1.1 Basics

Modes Arten der Selektion

• Neue Selektion ersetzt die alte

• Neue Selektion wird hinzugefügt

• Einen Teil aus einer Selektion ausschneiden

• Schnittmenge zwischen zwei sich überschneidenden Bereichen

Antialiasing Umrandung der Selektion wird glatter gezeichnet

Feather edge Umrandung wird unscharf, indem die Randpixel nur teilweise
ausgewählt werden. Damit verschmilzt die Auswahl sanft mit dem Hin-
tergrund.

Rounded corners Abrunden der Ecken der Selektion, mit dem Menü kann
der Eckenradius vergrößert werden

Expand from centre Vergrößert die Selektion ausgehend von der Mitte

Fixed Verändern der Form des Rechtecks

• Aspect Ratio: Verändern der Selektion mit festem Seitenverhältnis

• Breite

• Höhe

• Gröse: Breite und Höhe anpassen
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Abbildung 8: Eliptische Selektion

Position Platzierung der Selektion: Default: obere linke Ecke, wenn Expand

from centre aktiviert ist, dann die Position des Zentrums.

Size Größe, kann anstelle der direkten Änderung auf dem Bild verwendet wer-
den.

Highlight Hervorhebung der Selektion durch Abdunkeln der Umgebung, macht
die optische Selektion einfacher

Guides Auswahl der Führungslinien

• No Guides: keine Führungslinien

• Centre lines

• Rule of thirds

• golden selection

Auto Shrink Verkleinern der Selektion zur kleinsten rechteckigen Form in der
Selektion

Shrink merged Bei gesetztem Häckchen benutzt Auto Schrink die Pixelinfor-
mation im sichtbaren Bereich des Bildes anstatt des aktiven Layers

2.2 Elipsen

Die Optionen sind die gleichen wie bei der Rechteckselektion.
Wenn man einen Kreis auswählen möchte, geht dies durch setzen des Hächkchens

bei Aspect Ratio fixed und dem Verhältnis 1:1
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Abbildung 9: Freihandselektion

2.3 Lasso/Freihand

Die Freihandselektion ist ein Selektionswerkzeug, das nur Basisoptionen hat.
Gerade Linien erhält man durch Anklicken (nicht festhalten) eines Punktes
und dann Klicken eines zweiten Punktes, beliebige Linien durch Festhalten der
Maustaste beim Ziehen. Doppelklick auf das Ende der gezogenen Selektion ver-
bindet Anfangs- und Endpunkt mit einer gerade Linie.

Das Freihandtool hat die Optionen:

• Modes

• Antialiasing

• Feather edge

2.4 Lupe/Zoom

Option:

• Auto-resize window, Aktivieren führt dazu, dass das Fenster entsprechend
der Größe des gewählten Ausschnittes angepasst wird.

• Zoom in durch Aufziehen eines Fensters, Zoom out durch Str und Ziehen
eines Fensters.

2.5 Zirkel/Messure

Misst die bei einer Linie die Länge, Höhe, Breite und den Winkel zur Waagere-
cheten.
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Abbildung 10: Lupe/Zoom

Abbildung 11: Lupe/Zoom
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Abbildung 12: Text

Use info window öffnet ein Fenster wenn eine Messung beginnt, gibt Länge,
Höhe, Breite und Winkel.

2.6 Text

Erzeugen eines Textlayers

2.6.1 Optionen:

Font Auswahl der Schriftart

Size Schriftgröße

Hinting Verändern der Buchstaben um deutliche Buchstaben in kleiner Schrift-
gröse zu erzeugen

Force auto-hinter versucht automatsich Informationen für bessere Darstel-
lung der Schrift zu berechnen

Antialiasing glattere Darstellung

Colour Textfarbe

Justify Textausrichtung (linksbündig, rechtsbündig, zentriert, blocksatz)

Indent Abstand vom linken Rand

Line spacing Zeilenabstand

Character spacing Abstand zwischen den Buchstaben
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Text along Path Platziert den Text entlang eines Pfades.

Um einen Text entlang eines Pfades zu erzeugen, muss zuerst der Pfad an-
gelegt werden, bevor diese Option ausgewählt werden kann.

Text wird in einem Texteditor eingegeben, der die folgenden fünf Optionen
hat:

Open Text aus einem Textfile herausladen

Clear Entfernt allen Text

LTR Text wird von links nach rechts eingegeben

RTL Text wird von rechts nach links eingegeben (z.B. Arabisch)

Use selected font legt fest, ob die Schriftart aus dem Optionsdialog verwen-
det wird

2.7 Blesitf/Freihandzeichnen/Geraden

Quelle:http://docs.gimp.org/en/gimp-tool-pencil.html, http://docs.gimp.org/en/gimp-
tools-paint.html#gimp-tool-brush

Wird für Freihandlinien benutzt, die Linie hat harte Kanten, kein Antialia-
sing

Gerade Linien werden durch Drücken von Str erzeugt.
Wird benutzt, um Pixelgenau zu arbeiten.

2.7.1 Optionen

Mode wird bei Layern

Opacity Transparenzlevel (Deckkraft)

Brush Form und Größe des Stiftes (in Pixeln)

Scale Verändern der Größe des Stiftes
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Fade out Verblassen des Striches über die eingestellte Strecke.

Apply Jitter Striche werden über den eingestellten Bereich verteilt.

Incremental Wenn das Häckchen gesetzt ist und die Deckkraft nicht maximal
ist, wird die Deckkraft durch mehrfaches Drüberfahren erhöht (bis zur
maximalen Deckkraft des Werkzeugs)

Color from Gradient Verwenden eines (sich wiederholenden) Gradienten.

2.8 Pinsel/Geraden

Geraden lassen sich mit Shift drücken zeichen, ansonsten gleiche Optionen wie
der Bleistift, aber weiche Kanten

2.9 Radierer

Entfernen von Pixeln, gleiche Optionen wie der Bleistift

2.10 Füllen

Füllen einer Auswahl mit der aktuellen Vordergrundfarbe. Mit Ctr+click wird
die Hintergrundfarbe benutzt. (oder Umschalten mit der Maus)

Fill Auswahl zwischen Vordergrund- und Hintergrundfarbe und Füllen mit ei-
nem Muster

Affected Area Fill whole section Füllen eines gesammten selektierten Be-
reichs, Fill similar colors Füllen ähnlicher Farben im ausgweählten
Bereich

Find Similar Colors Einstellen der Farbschwelle

3 Bildbearbeitung

3.1 Geraderichten von Bildern

Beispiel: Geraderichten der Horizontlinie
1. Schritt: Ausmessen des Winkels, um den die Wasserlinie gekippt ist
2. Schritt Drehen des Bildes mit dem ausgemessenen Winkel

3.2 Stuerzende Linien

stürzende Linien lassen sich mit dem Perspektiv-Korrektur-Werkzeug korriege-
ren.

Mit Hilfe des Perspektivkorrekturwerkzeuges werden die Ecken so verzogen,
dass alle senkrechten Linien, die durch den Perspektivfehler schräg aussehen,
wieder senkrecht sind und parallel zueinander stehen. Und zwar werden bei
Architekturbildern in der Regl die oberen Ecken nach innen verschoben und die
unteren Ecken gleich weit nach außen.
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Abbildung 13: Geraderichten Horizontlinie

3.3 Freistellen

Quelle: http://de.wikibooks.org/wiki/GIMP/_Tutorials/_Objekte_freistellen
Freistellen eines Objektes bedeutet, ein Objekt auszuwählen und den Hin-

tergrund zu entfernen.
Eine Möglichkeit, das Objekt freizustellen, ist die Scissors select tool,

eine andere die forgroundselection (an den fliegenden Möwen demonstrieren)

4 Linsenfehlerkorrektur

Die Korrektur von Linsenfehlern (Tonnenfehler) wird am Beispiel einer Bilder-
folge demonstriert

Optionen des Filters

main Größe der spärischen Korrektur, positive Werte machen das Bild konvex,
negative konkav.

edge zusätzliche Korrektur an den Ecken

zoom Vegrößerung oder Verkleinerung durch die hypothetische Linse

brighten Erhöhen oder erniedrigen der Helligkeit an den Rändern (verursacht
durch Linsenkrümmung, die zu unterschiedlicher Lichtabsorption führt)

x-shift, y-shift Shift eines Bildes durch nicht perfekt zentrierte Linsen

5 Digitale Bilder

Eine Rastergraphik besteht vereinfacht aus in einem diskreten Koordinatensys-
tem eingetragen Farbinformationen. Alternativ können die Bilder aus Vektoren
bestehen, sind dann aber für den Gimp-Kurs nicht relevant.

Bei einer Rastergraphik (Pixel-Bilder) wird jedem Punkt in diesem Koor-
dinatensystem eine Farbinformation zugewiesen. Jeder dieser Bildpunkte wird
Pixel genannt. Jedes Pixel besteht aus einer Farbinformation, die in verschiede-
nen Farbmodellen dargestellt werden kann.
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Abbildung 14: Ausgangsbild

Abbildung 15: Anpassen des Grids
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Abbildung 16: Drehen

Abbildung 17: Dialog Linsenfehler
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Abbildung 18: Menü für die Korrektur des Linsenfehlers

Abbildung 19: Zuschneiden des Bildes
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Abbildung 20: fertiges Bild

5.1 Farbmodelle

Es existieren verschiendene Farbmodelle. Die Farbinformation wird in einem
Pixel-Bild einem Numerischen Wert zugewiesen. Diese Digitalisierung der Far-
binformation kann mit verschiedenen Farbräumen und Farbtiefen passieren.

5.2 Farbtiefen

Häufig verendete Farbtiefen:

1 Bit Schwarz/Weiß

2 Bit 4 Abstufungen (Halbton, EGA-Graphik)

4 Bit 16 Abstufungen

8 Bit 256 Abstufungen

16 Bit 65.536 Abstufungen

24 Bit meist 3x8 Bit, genutzt für Rot, Grün, Blau (RGB) ( 16.7 Mio. Abstu-
fungen)

32 Bit 3x8 Bit RGB, 8 Bit Alpha-Kanal

36-48 Bit 3x12-3x16 Bit teils genutzt in hochwertigen DSLR-Kameras (RAW)
und Repro-Scannern

Alpha-Kanal: Transparenzinformation, Historisch wurden Glas-Mattes im
Film (Bilder auf Glas gemalt zwischen Objekte gelegt) genutzt, der Alpha-Kanal
stellt das digitale Equivalent zur Objekttransparenz auf den Mattes dar.
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5.3 Farbräume

Der Farbraum beschreibt die numerische Representation der Farbe als digitalen
Wert. Beispiele für die Darstellung sind die Zerlegung in Farben (Rot, Gelb,
Blau (RGB) aus Lichtmischung; Cyan, Magenta, Gelb, (Schwarz) (CMY(K))
aus Druckfarbenmischung), in HSB (Farbton, Sättigung, Helligkeit engl.: Hue,
Saturation, Brightness).

Es gibt darüberhinaus Farbräume wie CIE-XYZ oder den Lab-Farbraum,
die die Wahrnehmung der Farben in einem Farbraum bei der Digitalisierung
berücksichtigen. Beispielsweise wird im L*a*b*-Farbraum die Farbe durch Ko-
ordinaten L∗, a∗, b∗ beschrieben, wobei L∗ (Luminanz) die Neutralgrauachse
bezeichnet, a∗ stellt dabei die Rot-Grün-Gegenfarbparameter und b∗ Blau-Gelb-
Gegenfarbparameter dar.

Luminanz vs. Helligkeit: Luminanz beschreibt die Helligkeit eines Bild-
punktes, physikalisch entspricht sie der Leuchtdichte in cd/m2. Die Helligkeit
dagegen beschreibt den Unterschied zwischen Hell und Dunkel, physikalisch geht
es bei der Helligkeit in Bildbearbeitungsprogrammen um eine farbmetrische Hel-
ligkeit, die sich von der photometrischen Helligkeit unterscheidet, indem sie als
Differenz der photometrischen Helligkeiten (oder besser Lichtstärke gemessen
in cd) zu einer unbunten Referenzfarbe gemessen wird und nach der Wahrneh-
mung (logaritmisch zwischen gemessener und wahrgenommener Lichtintensität)
gewichtet wird.

Sättigung: Die Stättigung beschreibt, als wie
”
bunt“ eine Farbe wahrgenom-

men wird, d. h. wie sehr eine Farbe an die zugehörige reine Spektralfarbe her-
ankommt.

Farbton [aus Wikipedia]: Der Farbton bezeichnet in der Farbenlehre (per
definitionem) die Eigenschaft, nach der man Farbempfindungen nach rot, gelb
oder grün unterscheidet. Eine Farbe desselben Farbtons kann entweder in der
Farbsättigung variieren, wie graublau oder in der Helligkeit, beispielsweise rosa.

Eine Farbe kann durch Angabe dieser drei Eigenschaften eindeutig beschrie-
ben werden; sie spannen einen dreidimensionalen Raum auf, den sogenannten
HSV-Farbraum, andere Koordinaten werden für weitere Farbräume genutzt.
Durch die grundsätzliche Existenz eines Farbtons unterscheidet man die bunten
Farben von den unbunten Farben: Der dem Farbton zugeordnete Farbwert wird
daher auch Buntton genannt, und typischerweise als Bunttonwinkel angegeben.

Durch die Wellenlänge des monochromatischen Lichts eines Farbtons kann
der Farbton nur näherungsweise beschrieben werden, für Farben der Purpurlinie
wird häufig die komplementäre Wellenlänge im Farbkreis gegenüber angegeben.
Für die Farbvalenz wesentlich ist nur das Verhältnis der Reizung der einzelnen
Farbrezeptoren im Auge, die unter anderem auch durch eine Anpassung an die
Lichtverhältnisse in der Umgebung und durch die Summe der benachbarten
Farbreize im Blickfeld des Betrachters veränderlich ist.

Farben können auch über die Bestandteile gewisser Grundfarben exakt de-
finiert werden. Bei der Additiven Farbmischung sind dies Rot, Grün und Blau
(RGB), bei der Subtraktiven Farbmischung Cyan, Magenta und Gelb (Cyan,
Magenta, Yellow = CMY). Für Anwendungen der Farbmetrik sind dies die theo-
retischen Farben X, Y und Z.
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5.4 Farbdarstellung in GIMP

GIMP arbeitet intern mit RGB+α und greift an einigen Stellen (z.B. blend
modes, Entsätigung etc.) auf andere Farbmodelle (insbesondere HSB) zurück.
CMYK wird zwar intern unterstützt, ist aber für den Anwender nicht zugänglich.

6 Histogramm

Ein Histogramm stellt eine grafische Darstellung von Häufigkeitsdichten dar.
Gimp zeigt das Histogramm unter Colors→ Info→ Histogram an. In Abbil-
dung 21 ist das Histgrammfenster dargestellt. Channel: Value stellt die Ver-
teilung der Helligkeitswerte im Bild da, die Kanäle Red, Green und Blue die
Verteilung der Helligkeitswerte für die einzelnen Farbkanäle.

Abbildung 21: Ein Histogramm

Das Histogramm begenet uns an verschiedenen Stellen nochmal insbesondere
treffen wir es gleich im Levels- und im Curves-Menü wieder.

7 Levels

Das Levelsmenü findet sich unter Colors→Levels.... Das Levelsmenü erlaubt
die vorhandenen Farbwerte auf andere Farbwerte zu mappen. In Abbildung 22
ist das Menü dargestellt.

Das Menü zeigt unter Inputlevels das Histogramm des darüber ausgewählten
Farbkanal. Rechts kann ich die Anzeige zwischen logarithmischen und linearen
Histogrammansichten umzuschalten. mit Unter dem Histogramm ist eine Farb-
verlaufsskala zu erkennen, die zeigt, welche Helligkeiten der jeweiligen Farbe
(oder der summarischer Farbwerte Value) zugeordnet sind. Über den linken
und rechten dreieckigen Schieberegler kann man den zu mappenden Bereich
enschränken, der mittlere dreieckige Regler ist der sogenannte Gamma-Regler,
der in der Regel in der Mitte zwischen dem linken und rechten Regler sitzt und
die Helligkeitswerte/Farbanteile Iin über die einfache Funktion Iin = Iγout auf
die Ausgabeskala mappt (zumindest, wenn die Implementierung dem entspricht,
was in der Hilfe steht).
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Abbildung 22: Levels-Werkzeug

Mapping Mathematisch sieht das Mapping der Farbwerte I(~x) folgenderma-
ßen aus:

Iin(~x) =
I(~x)− Iin,min

Iin,max)− Iin,min
dabei ist ~x die 2D-Koordinaten des Pixels und I( der Farbvektor des Pixels mit
R,G,B oder R,G,B, α wobei R,G,B, α ∈ 0, ..., 255. Iout(~x) representiert damit
die zu errechnende Farbinformation an der Kordinate ~x. Iin, Iin,gamma ∈ 0, ..., 1.
Anschließend wird die Gamma-Transformation durchgeführt:

Iin,γ(~x) = Iin(~x)γ

Diese Eingabewerte werden nun in die Ausgabewerte umgerechnet, wobei

Iout(~x) = Iin,γ(~x) · (Iout,max − Iout,min) + Iout,min

Anschließend werden die Ausgabewerte gerundet, negative Werte auf Null ge-
setzt und Werte ≥ 255 auf 255 gesetzt.

7.1 Kontrast

Kontrast beschreibt den Helligkeitsunterschied zwischen benachbarten Bildbe-
reichen. Auch Farbunterschiede können eine Kontrastwahrnehmung hervorru-
fen.

Ein Bild mit schwachem Kontrast ist z.B. in Abbildung 23 dargestellt. Mit
der Levels-Funktion kann der wahrgenommene Kontrastumfang des Bildes erhöht
werden. Dafür wird der Eingangsbereich begrenzt. Nach dem Bestätigen der vor-
genommenen Einstellungen werden die Farben neu gemappt und man erhält ein
gedehntes Histogramm mit Lücken wie sie in Abbildung 24 dargestellt.

Das Ergebniss der Operation zeigt einen höheren Kontrast (vgl. Abb. 25),
es sind jedoch einige Tonwerte im Bild nicht mehr besetzt.

20



Abbildung 23: München mit schlechtem Kontrast

Abbildung 24: Begrenzung der Eingangsbereiche mittels Levels und das ein-
mal damit bearbeitete Bild; man beachte die Werteverteilung (insbesondere die
entstandenen Lücken) im Histogramm

Die Einstellungen können als Voreinstellungen gespeichert und zu einem
späteren Zeitpunkt wieder abgerufen werden.

7.2 Weißabgleich

Der Weißabgleich wird dann notwendig, wenn man Bilder mit einem Farbmap-
ping vorliegen hat, das nicht den erwarteten Farben entspricht. Das Gehirn ist
in der Lage einen Menschen sehr effektiv über Farben zu belügen (Wer es nicht
glaubt: vgl. Abb. 26).

Digitale Kameras und Scanner sehen aber leider nicht mit einem psychologi-
schen Sehmodell und können daher bei der Abbildung von Farben oft ziemlich
weit von der Erwartung abweichen. So ist ein weißes Blatt papier, wenn es von
einer Leuchtstoffröhre angeleuchtet wird auf der Aufnahme blaugrün. Wenn mal
das Blatt selber sieht, erscheint es trotzdem weiß, obwohl es für eine Farbmes-
sung (wie sie von einer Digitalkamera vorgenommen wird) erst einmal nicht weiß
ist.

Automatischer Weißabgleich versucht im einfachsten Fall die Farbwiedergabe
dadurch zu bestimmen, dass versucht wird die Histogramme für RGB auf eine
maximale überdeckung gebracht werden. Alternativ wird angenommen, dass
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Abbildung 25: München mit schlechtem Kontrast links und bearbeitete Version
rechts

das hellste Pixel weiß ist und die Farben entsprechend im Histogramm mittels
einem Offset verschoben werden, so dass das Pixel RGB=255,255,255 wird. Diese
Methoden funktionieren in sehr vielen Fällen gut. Wenn es schief geht, muss man
selber Hand anlegen.

In dem Beispielfoto 27 sieht man den Effekt eines falschen Weißabgleichs
in der Kamera. Das Licht während der Aufnahme war Tageslicht der Weißab-
gleich war in der Kamera erwartete das Farbprofil einer Leuchtstoffröhe und
stellt das Bild deshalb mit einem starken türkis-/blau-grün-Stich dar. Um die-
sen zu korrigieren kann man einen manuellen Weißabgleich durchführen. Dabei
bietet es bei diesem Photo an, nicht nur den Weißpunkt manuell vorzugeben,
sondern zusätzlich einen schwarz und einen 18%-Graupunkt. Beim Fotografieren
kann man diese Punkte durch eine sogenannte

”
Weißabgleichskarte“, Graukarte,

einen Weißabgleichfilter oder eine Farbkalibrationskarte (Abb. 28 mit mehreren
Farbfenstern zum erstellen eines Kamerafarbprofils).

Für den manuellen Weißabgleich fehlt uns in diesem Beispiel eine Graukarte.
Dafür sieht man auf dem Bild schwarze, hellgraue und weiße Bereiche, so dass
man diese als Referenz Werte angeben kann. Die Operation findet also in drei
Schritten statt: Als erstes wählt man den Schwarzpunkt – hier der scheinbar
dunkelste Punkt im Hintergrund –, dann ein helles Grau – hier aus dem Fell am
rechten Vorderbein – (hierbei muss man etwas raten oder herumprobieren, was
gut aussieht) und den Weißpunkt von einer der Pfoten (vgl. Abb. 29 bis Abb.
31). Bereits nach der Wahl des Schwarzpunkts zeigt das Bildergebnis schon
deutlich besser passende Farben, die Grau- und Weißpunktwahl verändert das
Ergebnis nur in wenigen Details. Daher ist ein Weißabgleich auch möglich, wenn
man nur einen Weiß-, Grau- oder Schwarzpunkt auswählt. Die Reihenfolge der
Wahl beeinflusst das Ergebnis dabei weniger, als die Reproduzierbarkeit der
Wahl des Punktes. Beim Weißabgleich werden die Weißpunkte für die Farb-
kanäle einzeln gewählt, der Gammapunkt verschoben und die Ausgabebereiche
teilweise eingeschränkt. Das Ergebniss ist in Abbildung 32 zu sehen.

Nun gehen wir nochmal zu Abbildung 22 zurück. Es gibt hier noch einen
zusätzlichen Knopf Edit these Settings as Curves. Diesem wollen wir jetzt
folgen. mit
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Abbildung 26: Die blauen Felder auf dem gelben Hintergrund und die gelben auf
dem blauen Hintergrund sind grau. Die mittleren Felder oben und an der Sei-
te haben die selbe Farbe [http://www.lottolab.org/illusiondemos/Demo%
2012.html]

8 Curves

Das Curves-Werkzeug findet man beispielsweise im Menu Colors->Curves...

oder im Levels-Werkzeug. Das Curves-Werkzeug funktioniert ähnlich wie das
Levels-Werkzeug. Es erlaubt ein etwas komplizierteres Mapping als bei Levels
möglich, da bei Curves die Funktion deutlich freier festgelegt werden kann. Im
Normalfall ist die Funktion mit der die Farbwerte von einem auf dem anderen
Wert gemappt linear oder exponentiell. Bei Curves (Curves type: Smooth)kann
ich durch das Hinzufügen von Sattel- bzw. Wendepunkten in einem Koordina-
tensystem eine

”
geschwungene, stetige Mappingfunktion“ erzeugen. Das Curves

tools geht sogar noch ein Stück weiter und erlaubt mit Curves type: Freehand

sogar nicht stetige Mappingfunktionen, die ich
”
freihändig“ in mein Koordina-

tensytem zeichen kann.
Nochmal wiederholen:

Value Helligkeitswert (Summe der Farbwerte/3)

R,G,B-Kanäle jeweiliger Anteil der Farben in der Farbmischung

Alpha Transparenzinformation

8.1 Curves statt Levels

8.2 Farbanpassungen, Kontrast

Die Farbanpassungen mittels Curves erlaubt viele Farbveränderungen. Ein Bei-
spiel zeigen wir in Abbildung 35.
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Abbildung 27: Anton mit falschem Weißabgleich

Abbildung 28: Beispiel für eine Farbreferenzkarte [http://www.
enjoyyourcamera.com/Grey-Cards-White-Balance/Grey-cards/

DGK-DKC-Pro-Color-reference-card-Gray-card::4421.html]
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Abbildung 29: Weißabgleich in drei Schritten, Schritt 1: Wahl eines Schwarz-
punkt

Abbildung 30: Weißabgleich in drei Schritten, Schritt 2: Wahl eines Graupunkt
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Abbildung 31: Weißabgleich in drei Schritten, Schritt 3: Wahl eines Weißpunkt

Abbildung 32: Ergebiss des Weißabgleichs im Levels-Dialog
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Abbildung 33: Das Curves-Werkzeug

Abbildung 34: Nutzung von Curves analog zur Eingangsausschränkung im
Levels-Dialog
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Abbildung 35: Beispiel für einen höheren Kontrast und intensivere Farben mit-
tels Curves
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9 Bildebenen und Ebenenmasken

• Bildebenen sind vergleichbar mit aufeinanderliegenden Dias/Folien

• Bildebenen sind sortierbar, untereinander koppelbar, sichtbar oder un-
sichtbar

• Die Ebenengröße hängt nicht zwingend mit der Bildgröße zusammen, son-
dern kann größer oder kleiner sein (Beispiel: Texte)

• Bei einem Photo ist das Foto automatisch die Hintergrundebene, auf der
gearbeitet wird, solange keine neue Ebene angelegt ist.

• Die Ebene auf der gearbeitet wird ist weiß hinterlegt. Ebenenmasken wer-
den, wenn sie aktiviert sind, weiß hinterlegt, sonst schwarz.

• Translationswerkzeuge arbeiten auf verknüpften Ebenen

• Selektionen und Pixelwerkzeuge arbeiten nur auf der aktiven Ebene

• Eine Ebene hat je einen RGB und α-Kanal.

• Eine Ebenemaske hat einen Überblendeeffekt (blend mode) und eine Deck-
kraft (Opacity)

• Eine Ebene kann eine Ebenenmaske haben.

• Eine Ebenenmaske bestimmt die lokale Transparenz der Ebene (zusätzlich
zum α-Kanal)

9.1 Ein Beispiel für Ebenen

Ein Beispiel findet sich in den Abbildungen 36 bis 50. In Abbildung 36 exsistiert
genau eine Ebene, der Hintergrund. Abbildung 37 zeigt das Menü zum Erstellen
neuer Ebenen und Ebenenmasken (Rechtsklick auf Ebene). Wir erstellen eine
neue Ebene.
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Abbildung 36: Neues Bild mit weißem Hintergrund
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Abbildung 37: Kontextmenü für Ebenen
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Abbildung 38 zeigt die Optionen zum Erstellen eines neuen Layers. Unser
neuer Layer bekommt die selbe größe wie der Hintergrundlayer und wird voll-
transparent.

Abbildung 38: Create a New Layer-Dialog
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Abbildung 39: Ein blaues Rechteck in einem transparenten neuen Layer

Im nächsten Schritt (Abb. 39) haben wir nun eine neue Ebene. Wir akti-
vieren die Ebene durch anklicken und selektieren ein Rechteck, dass mit dem
Füllenwerkzeug jetzt gefüllt wird. Durch Doppelklick auf den Ebenennamen
kann dieser geändert werden. In Abb. 40 blenden wir die Ebene mit dem blauen
Rechteck erstmal wieder aus.
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Abbildung 40: Vorheriges Bild (39, wobei der Layer mit dem Rechteck ausge-
blendet wurde
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In den nächsten Schritten wiederholen wir die Schritte aus den Abbildungen
37 bis 40. Wir erzeugen uns zwei neue Layer, die jeweils ein grafisches Element
(eine rote Ellipse (Abb. 41 und ein grünes Rechteck 42) enthalten.

Abbildung 41: Zusätzlicher Layer mit roter Ellipse
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Wenn wir nun alle drei Ebene wieder einblenden sieht da Ergebnisbild wie
in Abbildung 42 dargestellt aus. Die Kanäle sind nun im Layers-Menu wie in

Abbildung 42: Zusätzlicher Layer mit grünen Rechteck

Abbildung 43 angeordnet (von oben nach unten):

• Grünes Rechteck (zuletzt angelegter Layer, im Vordergrund)

• Rote Ellipse

• blaues Rechteck

• Hintergrund (als letzte Ebene)

Abbildung 43:
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Wenn wir jetzt eine Ebene im Layers-Dialog selektieren wird diese aktiv.
Wenn wir sie jetzt verschieben verändert es nur die Position der Objekte auf
der aktiven Ebene. Hier im Beispiel (44) ist die Ebene mit der roten Elipse aktiv
und wird verschoben.

Abbildung 44: Verschieben der aktiven Ebene
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Abbildung 45: Layers-Dialog: Die Ebenen rote Ellipse und blaues Rechteck sind
gekoppelt

Wenn ich nun die aktive Ebene verschiebe, ändert sich die Position der ge-
koppelten Ebenen mit.

9.2 Ebenenmasken

Zusätzlich zur Transparenzinformation im α-Kanal kann ein Layer eine Eben-
maske haben. Die Ebenemaske ist ein Graustufenbild, bei dem weiß voller Deck-
kraft und schwarz vollständiger Transparenz entspricht. Abstufungen in der
Deckkraft können durch Zwischenwerte erzeugt werden.

Beim Erzeugen gibt es folgende Optionen:

• weiß: Analog zu keiner Maske

• schwarz: Bild ist volltransparent

• α-Kanalkopie des Layer (dabei wird die Transparenzinformation des Bildes
in die Layermaske verschoben (transparente Bereiche in schwarz, deckende
Bereiche Weiß). Der α-Kanal bleibt dabei erhalten.

• Graustufenbild des Layers (die dunklen Bereiche des Bildes werden trans-
parent, helle Bereiche deckend)

• Farbkanäle Rot, Grün, Blau (je nach Farbwahl werden die roteren/grüneren/blaueren
Bereiche transparenter)

• α-Kanaltransfer: Der α-Kanal des Bildes wird in die Layermaske verscho-
ben, im α-Kanal wird die Deckkraft auf voll gesetzt.

Daneben kann jede dieser Möglichkeiten invertiert werden (Mathematisch: (255-
Pixelfarbwert)
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Abbildung 46: Beispiel für das verschieben gekoppelter Ebenen
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Abbildung 47:

Abbildung 48:
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Abbildung 49:

Abbildung 50:
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9.3 Übung: Freistellen mit Layermasken

• Motiv mir Freihandauswahl grob vorauswählen

• Maske aus Selektion erstellen

• Layermaske zum Bearbeiten auswählen

• Mit relativ großem, weißem Bleistift (z.B. Pencil, Circle 19 Scale 5) die
Maske anpassen, bis sie relativ gut passt

• mit Pinsel oder Bleistift (niedrige Deckkraft, Inkrementel, Opacity 5%-
10%, Fuzzy Circle) Details ausarbeiten, dabei Übergänge an Kanten sanft
auslaufen lassen (weicher Übergang von weiß nach schwarz, im Zweifel
Filters->Blur->Gaussian Blur) [vgl. Abb. 51]

• Manchmal ist das Hinterlegen mit einer kontrastierenden Farbe (rosa,
grün, orange) hilfreich, da man dann den Transparenzaspekt besser einschätzen
kann. [Ergebnis 52]

Abbildung 51: Eine Möwe und die zugehörige Layermask, mit der sie freigestellt
wird

9.4 Colorkey

• Bild öffnen

• Hintergrundebene duplizieren

• kopierte Ebene in graustufen umwandeln durch Colors -> Entsättigen,
Colors -> Components -> Kanal-Mixer, Colors -> Components -> Decompose,
Colors -> Hue Saturation ...,. . . nicht durch Mode -> Grayscale

• Layermaske hinzufügen (weiß, volle Deckkraft)

• Layermaske selektieren

• mit schwarz Bereiche auswählen, die durchscheinen sollen

Beispiele: colorkey.xcf (Abb. 53), Caja-colorkey.xcf
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Abbildung 52: Die freigestellte Möwe auf einer rosa Ebene

10 QuickMask

QuickMask dient der Auswahl oder der Verbesserung/Veränderung einer beste-
henden Auswahl und verhält sich wie ein Alpha-Kanal einer Selektion. Einfach
unten auf das kleine Quadrat unten links im Bildbearbeitungs klicken und mit
256 Graustufen die Selektion unterschiedlich stark durchführen. Je weißer desto
stärker wirkt die Selektion und desto weniger transparent ist sie.

Die
”
wanderenden Ameisen“ werden nur für Selectionen mit einer Selektion

über 50% angezeigt (Grauwert ≥ 128), weniger stark selektierte Bereiche liegen
außerhalb, sind aber trotzdem (transparent) selektiert.

11 Kochrezepte

Der nächste Abschnitt enthält einige Kochrezepte, die einen guten Start für
eine bestimmte Aufgabe bieten. Die Parameter die angegeben sind funktionie-
ren oft gut für Bilder mit einer Auflösung zwischen 4 und 10 Megapixel. Aber
wie bei Kochrezepten auch handelt es sich um Basisrezepte, die einen gewissen
Geschmack treffen und nicht allzu kompliziert nachzukochen sind, aber man
darf natürlich Zutaten (Einstellungen) variieren und nicht jedes Rezept hat das
Potential zum Lieblingsessen.
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Abbildung 53: Beispiel eines Colorkeys

11.1 Rote Augen entfernen

Das Rote-Augen-Entfernen-Plugin von Gimp taugt leider nichts (einfach mal
ausprobieren)

• Bild öffnen

• sicherheitshalber Layer kopieren

• Layerkopie aktivieren

• in Channel-Dialog wechseln

• Sichtbarkeit für Kanäle Blau und Grün deaktivieren

• Dodge & Burn-Tool auswählen

• Brush: Fuzzy Circle, Type: Burn, Range: Highlights, Deckkraft: 100%,
Exposure nach Geschmackwerten

• fertig

11.2 Rauschen reduzieren

Filters -> Blur -> Selective Gaussian Blur, Radius 5, Schwellenwert 10-
20; funktioniert ganz gut, gegebenfalls nach unten angegeben Rezept Kanten
nachschärfen

11.3 Farbrauschen reduzieren

• Bild öffnen

• Colors -> Components -> Decompose

• Colormodel: HSV,
”
Decompose to layers“
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• Hue-Ebene auswählen

• Filters -> Blur -> Gaussian Blur

• Einstellung: Radius 5, Methode RLE

• die letzten zwei Schritte für die Sättigung wiederholen

• Colors -> Components -> Compose

• fertig

Nicht perfekte Methode, ebnet Farbrauschen besser ein als Filters -> Enhance

-> Despecle. Alternativ, kann man die den reduzieren. Alternativ:

• Bild öffnen

• Filters -> Generic -> High Pass Filter

• Einstellungen: Filterradius: 10, Contrast Adjust: 0 ,Mode: Color, Keep
Original Layer

• Das Filterergebnis wird als <Ebenenname> high pass angezeigt und enthält
Kanten und Rauschen. Die Ebene auf Layermode grain extract.

• fertig

Das Verfahren reduziert neben Farbrauschen auch Helligkeitsrauschen und eig-
net sich damit relativ gut. Die Bildschärfe nimmt dabei aber generell ab.

11.4 nicht farbiges Rauschen reduzieren

• Bild öffnen

• Colors -> Components -> Decompose

• Colormodel: LAB,
”
Decompose to layers“

• A-Ebene auswählen

• Filters -> Blur -> Gaussian Blur

• Einstellung: Radius 5, Methode RLE

• die letzten zwei Schritte für die B-Ebene wiederholen

• L-Ebene schärfen mit Unsharp Mask

• Colors -> Components -> Compose

• fertig
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11.5 Selektives Schärfen an Kanten

• Bild öffnen

• Ebene duplizieren

• Ebenenmaske auf dublizierter Ebene mit Graustufenkopie anlegen

• Ebenenmaske auswählen

• Kantenerkennungsfilter unter Filters -> Edge-Detect -> Edge aktivie-
ren.

• Einstellungen (Algorithm: Sobel, Amount 2.0, black)

• Layermaske anzeigen, kontrollieren, ob Bereiche weiß sind, die nicht geschärft
werden sollten.

• Ebenenmaske weichzeichen (Filters -> Blur -> Blur)

• dublizierte Ebene aktivieren

• Ebene schärfen (Filters -> Enhance -> Sharpen, Einstellung Sharp-
ness 50)

• fertig

12 Schwarz-Weiß-Konvertierung von Farbbildern

Beide Menüs liefern ein RGB-Bild in Schwarz-Weiß, um ein wirkliches Graustu-
fen Bild zu erhalten. muss auch noch Image -> Mode -> Grayscale gewählt
werden, wobei nur noch 8bit Graustufen + α-Kanal erhalten bleiben.

12.1 Entstättigen

Das Entsättigenwerkzeug kann via Colors -> Desaturate aufgerufen werden.
Es dient dazu eine Ebene in Graustufen umzufandeln und liefert drei unter-
schiedliche Methoden das Bild zu entsättigen. In den nachfolgenden Abbildun-
gen ist ein Farbverlauf zu sehen, der im HSV-Farbmodell bei Saturation und
Value einen konstanten Wert von 255 (Weiss) und im Hue-Wert alle Farbtöne
von 0 bis 255 durchläuft. An diesem ist zu sehen, wie die einzelnen Operationen
das Bild endsättigen.

Lightness Die Farbwerte eines Pixels werden mittels folgender Formel be-
stimmt:

Grauwert =
1/2

·
(max(R,G,B) + min(R,G,B))

Das Ergebniss der Konvertierung ist in Abbildung 54 zu sehen.

Luminosity Luminosity entsättigt nach folgender Formel

Grauwert = 0.21 ·R+ 0.72 ·G+ 0.07 ·B

Dabei werden Blautöne dunkel und Grün-, Rot- und Brauntöne hell. Dies
ist in Abbildung 55 zu sehen.
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Abbildung 54: Entsättigung eines Farbverlaufs mittels
”
Lightness“

Abbildung 55: Entsättigung eines Farbverlaufs mittels
”
Lightness“
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Abbildung 56: Entsättigung eines Farbverlaufs mittels
”
Lightness“

Average Average mittelt zwischen den RGB Werten

Grauwert =
R+G+B

3
.

Das Ergebnis davon ist in Abbildung 56 zu sehen. Average entspricht dem
wahrgenommenen Helligkeitsverlauf in dem Bild, selbst wenn die rechneri-
schen Helligkeitsunterschiede (im HSV-Model der Wert VALUE) konstant
ist.

Dabei ist es vieleicht interessant, dass hautfarbene Bereiche des Bildes von
diesen unterschiedlichen Methoden nicht besonders stark unterschiedlich kon-
vertiert werden, so dass diese Methoden für Bilder mit Personen etwa gleich gut
geeignet sind.

12.2 Kanalmixer

Colors -> Components -> Channel Mixer (Abbildung 57) Der Kanalmixer
erlaubt eine feinere Kontrolle über die Mischung der Farben im Bild. Der Ka-
nalmixer beeinflusst die Multiplikationsfaktoren bei der Berechnung der Farben.
Zusätzlich gibt es eine Schaltfläche zur zur Konvertierung in

”
Monochrome“

(Graustufen). Dabei kann mit
”
Preserve luminosity“ die

”
Helligkeit“ des Bildes

erhalten werden. Die Regler für Rot, Grün und Blau sind Gewichtungsfaktoren,
die zwischen -200% und +200% eingestellt werden können. Damit ergibt sich
für die Schwarzweisskonvertierung folgende Formel

Grauwert =
Red

/
100 ·R+

Green

/
100 ·G+

Blue

/
100 ·B

Wenn man nun Beispielsweise ein Pixel mit dem RGB-Wert=10,20,30 hat und
Rot, Grün, und Blau jeweils hundert Prozent betragen, wird der Grauwert=10+20+30=60
und damit deutlich weisser als man erwarten würde, da hier 3x100% der Farb-
werte addiert werden. Preserve Luminosity sorgt dafür das die Regler so skalie-
ren, dass sie in der Summe Maximal Werte von 255 erreichen können, in unserem
Beispiel wäre der Skalierungsfaktor 1

3 . Dieser Skalierungsfaktor hängt aber von
den eingestellten Werten ab.
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Abbildung 57: Der Kanalmixer

49


	Öffen und Speichern
	Erstellen eines neuen Bildes
	Speichern eines neuen Bildes
	Bildformate

	Bild öffnen
	EXIF Daten


	Werkzeugkasten
	Rechteckselektion
	Basics

	Elipsen
	Lasso/Freihand
	Lupe/Zoom
	Zirkel/Messure
	Text
	Optionen:

	Blesitf/Freihandzeichnen/Geraden
	Optionen

	Pinsel/Geraden 
	Radierer 
	Füllen

	Bildbearbeitung
	Geraderichten von Bildern
	Stuerzende Linien
	Freistellen

	Linsenfehlerkorrektur
	Digitale Bilder
	Farbmodelle
	Farbtiefen
	Farbräume
	Farbdarstellung in GIMP

	Histogramm
	Levels
	Kontrast
	Weißabgleich

	Curves
	Curves statt Levels
	Farbanpassungen, Kontrast

	Bildebenen und Ebenenmasken
	Ein Beispiel für Ebenen
	Ebenenmasken
	Übung: Freistellen mit Layermasken
	Colorkey

	QuickMask
	Kochrezepte
	Rote Augen entfernen
	Rauschen reduzieren
	Farbrauschen reduzieren
	nicht farbiges Rauschen reduzieren
	Selektives Schärfen an Kanten

	Schwarz-Weiß-Konvertierung von Farbbildern
	Entstättigen
	Kanalmixer


